AnyView Explorer screen does not display any objects.

23 December 2003

Issue Description

Although successfully logged in, the AnyView Explorer screen does not display any objects. There can be a number of reasons for this:

Scenario #1

AnyView is not registered.

Scenario #2

There is a problem with the DSNs in the anyview.ini file.

Scenario #3

The Standard Objects and Gotos have not been imported.

Scenario #4

The user has not been granted access to any objects.

Solution

Scenario #1

  1. Log in to AnyView Creator.
    In a standard installation, choose 'Module' then 'AnyView' and click 'Creator'. When prompted, enter your password and click Login and Proceed'.
  2. In the upper left-hand corner of the screen, choose 'Options' then 'Registration'.
  3. In the lower left-hand corner of the screen is green text that indicates the registration status of AnyView Explorer.

Scenario #2

  1. Delete the anyview.ini file.
    In a standard installation, this file would be located in C:\Program Files\Solomon IV.
  2. Rerun the DSN Setup
    In a standard installation, this screen is available by selecting 'Modules', 'AnyView', then 'DSN Setup' to establish DSNs for Solomon IV.

Scenario #3

Import the Standard Objects and Gotos according to the instructions documented in the AnyView Administrator Guide section of the same name.
TIP - It is important to import the Gotos prior to importing the Objects.

Scenario #4

Explorer will only show Objects for which the user has access rights. Use the Solomon Access Rights Maintenance screen to grant users or groups access to Objects.
TIP - If you are using the Solomon Desktop, the Object numbers begin with "DT". If not, they will begin with "AV".

Site Map